OnlyOffice


"OnlyOffice" (anteriormente "TeamLab"), estilizado como "ONLYOFFICE", é uma suíte de escritório de código aberto desenvolvida pela Ascensio System SIA, uma empresa com sede em Riga, Letônia. A solução apresenta editores de documentos on-line de alto desempenho e plataforma para gerenciamento de documentos, comunicação corporativa, e-mail e gerenciamento de projetos.

OnlyOffice
Onlyoffice Logo
Página oficial www.onlyoffice.com

O OnlyOffice é entregue como uma solução SaaS ou como uma instalação para implantação em uma rede privada. O acesso ao sistema é realizado por meio de um portal privado on-line.

HistóricoEditar

O OnlyOffice começou em dezembro de 2009 com uma plataforma de colaboração simples que englobava várias funcionalidades computacionais sociais (blog, fórum, wiki, marcadores). Desde então o produto tem sido aprimorado para ir ao encontro das demandas crescentes das empresas sobre funcionalidades de gestão de projetos. Em julho de 2010 a Ascencio System lançou dois novos módulos em adição a Comunidade: Projetos (cuja meta é simplificar a gestão de projeto) e Bate-papo (mensagens instantâneas corporativas).

Em março de 2011 a empresa lançou uma nova versão 3.0 melhorada, que inclui um quarto módulo – Documentos (designado para armazenamento, compartilhamento, edição de arquivos diretamente no portal).

DocumentosEditar

Documentos - processador de textosEditar

O editor de textos possui os menus:

  • Arquivo
  • Página inicial
  • Inserir
  • Layout
  • Referências
  • Colaboração
  • Plugins

O menu Arquivo exibe ações para criar arquivos, fazer downloads, criar cópia, direitos de acesso e histórico de versão. É importante destacar as opções de direitos de acesso e histórico de versão, pois estão diretamente relacionadas com o trabalho colaborativo.

O menu Página Inicial exibe opções para formatação de textos, numeradores, parágrafos, título e subtítulos. As formatações selecionadas são imediatamente aplicadas e vários usuários podem editar o mesmo documento ao mesmo tempo.

O menu Inserir permite adicionar elementos não textuais ao documento, como por exemplo: nova página, cabeçalho e rodapé, tabelas, imagens, gráficos e símbolos. Um elemento que julgo muito interessante é a inserção de equação, que permite inserir fórmulas matemáticas no documento.

O menu Layout permite configurar tamanho da página, orientação (retrato ou paisagem), colunas, e alinhamento de itens gráficos. Um dos destaques desse menu é a marca d'água, que permite acrescentar textos ou imagens como marca d'água, deixando o documento muito elegante e personalizado.

Presente em muitos editores de textos mas de pouco conhecimento dos usuários, no menu Referências, pode-se criar índices automáticos, notas de rodapé e legendas. Todo usuário precisa conhecer esses recursos.

O menu Colaboração é o coração das configurações do trabalho colaborativo. Permite mudar os modos de edição, compartilhar o documento, destacar e recusar alterações e ainda permite conversar em tempo real com outros usuários que estão interagindo com o documento.

Por fim, o menu Plugins expande o poder do processador de textos do OnlyOffice com recursos disponíveis de outros softwares.

Documentos - planilha eletrônicaEditar

A planilha eletrônica possui os menus:

  • Arquivo
  • Página Inicial
  • Inserir
  • Layout
  • Fórmula
  • Data
  • Pivot Table
  • Collaboration
  • Plugins

O menu Arquivo disponibiliza opções para criar arquivos, abrir recentes, informações da planilha e downloads. É importante destacar a opção de Configurações Avançadas, onde podemos configurações relacionadas a regionalização e elementos de co-autoria.

Como fazer - DocumentoEditar

Como adicionar uma marca d'água no documento?Editar

Uma marca d'água é um texto ou uma imagem disposta ao fundo do documento para dar uma informação adicional ao documento. No menu Layout procure o item Marca d'água e clique em personalizar marca d'água. A caixa de diálogo apresenta as opções:

  • Nenhum
  • Marca d'água de texto
  • Marca d'água de imagem

Agora é só selecionar a opção e seguir as instruções da tela.

Como exibir números de linhasEditar

O editor de texto do OnlyOffice permite a contagem automática de linhas. Isso é muito útil para referenciar linhas em um documento, como um documento oficial, um contrato legal ou um script.

Selecione o menu Layout e procure a ferramenta número de linha. Se clicar na ferramenta opções de numeração automática de linhas serão listadas. A opção padrão é nenhum. Selecione a opção de numeração mais adequada ao seu trabalho e pronto, os números serão exibidos.

Como fazer - PlanilhaEditar

Como congelar a linha superior da planilha?Editar

Congelas algumas linhas ou colunas para permanecerem visíveis mesmo com a rolagem da tela pode ser muito útil. Para congelar uma linha ou coluna deve seguir esses passos:

1 - Selecione a linha subsequente ao conjunto de linhas que deseja congelar.

2 - Clique com botão direito do mouse sobre o indicador da linha.

3 - Selecione congelar painéis.

ExemploEditar

Se você quer congelar as linhas 1, 2 e 3, clique com o botão direito do mouse no indicador da linha 4 e clique em congelar painéis. Para descongelar, clique no indicar da mesma linha e selecione descongelar painéis (Unfreeze Panes).

Como contar os caracteres de uma célula?Editar

Pode ser útil sabermos o total de caracteres inserido em uma célula e isso pode ser obtido com a função len.

ExemploEditar

Para contar os caracteres de uma célula A1, é só usar a seguinte fórmula: =len(A1).

Como adicionar hiperlinks em uma planilha?Editar

Para adicionar um hiperlink,

  1. Selecione a célula onde o link será adicionado,
  2. Selecione o menu Inserir na barra de ferramentas,
  3. Clique no ícone Hiperlink e siga as instruções da caixa de diálogo.

Como criar uma lista suspensa?Editar

A lista suspensa permite que se defina quais valores podem ser escolhidos para alimentar uma célula. Isso pode ser muito útil para limitar quais valores podem ser inseridos em uma célula.

ExemploEditar

  1. Em uma planilha qualquer, digite os seguintes valores em um coluna: P, M, G, GG;
  2. Depois selecione em qual célula deverá ser inserida a lista suspensa;
  3. Selecione o menu Dados e depois a ferramenta Validação de dados;
  4. Na janela que abrir, selecione a opção Lista no campo Permitir;
  5. Selecione as células que contém os valores que devem ser exibidos na lista e então clique no botão OK;
  6. A lista será exibida com os valores P, M, G e GG.

Como calcular dias de atrasoEditar

Além de calcular os dias de atraso, o exemplo pode ser usado para calcular qualquer diferença, em dias, entre duas datas. Em uma célula deve ser inserida a data inicial, que para este exemplo seria a data de vencimento de um título e depois com as funções today() e days(), calcula-se a diferença entre os dias.

ExemploEditar

  1. Insira a data 01/06/2021 (ou qualquer outra data) na célula A2;
  2. Insira a fórmula =TODAY() na célula B2;
  3. Insira a fórmula =DAYS(B2;A2);
  4. A função DAYS() calcula a diferença em dias do primeiro parâmetro (data final) para o segundo parâmetro (data inicial).


Ligações externasEditar